[Mikrotik] NAT loopback / Hairpin NAT

죠짱   
   조회 21247   추천 8    

이거와 관련해서 여기저기 나오는게 영 다르고 해서
그냥 제가 설정 하나 만들어 보았습니다.
아래를 따라 가면 NAT 루프백 별로 어렵지 않게 세팅 가능 할겁니다.

0.
먼저 NAT루프백을 하려면 다음과 같이 Public IP를 얻어 올수 있게 세팅 해야 합니다.
시스템->스케쥴러에 등록 합니다. 인터벌은 1분 정도면 되겠습니다.


 # Set needed variables
:global extinterface "ether1-gateway"
:global ExtIpListName "external-ip"
:global extip ""
:global oldextip ""

# Grab the current IP address on that interface.
:local extip2 [/ip address get [/ip address find interface=$extinterface ] address];
:set extip [:pick $extip2 0 [:find $extip2 "/"]];

:if ([:len [/ip firewall address-list find list=$ExtIpListName]] > 0) do={
   :set oldextip [/ip firewall address-list get [/ip firewall address-list find list=$ExtIpListName] address];
   :if ($oldextip != $extip) do={
      /ip firewall address-list set [/ip firewall address-list find list=$ExtIpListName address=$oldextip] address=$extip
     :log info "External IP relpace from $oldextip to $extip"
   };
} else={
   /ip firewall address-list add list=$ExtIpListName address=$extip
   :log info "New external IP added: $extip"
};


그리고  IP->Firewall -> Address List에 external-ip 가 등록이 되었는지 봅니다.

1.
DNAT 의 설정 입니다.
IP -> Firewall -> Address List 에서 dstnat 을 등록할때.
Proto: TCP
Dst Port :1234
같이 할때에 In Out 인터페이스는 비우고 Dst Address List 에 external-ip 를 설정 해줍니다. (중요)
이건 DNAT 할때에 인터페이스 기준이 아니라 Public IP 기준으로 잡아 주는 겁니다. (내부에서 타고 들어갈때에 중요.... 보통 이런 저런 강좌에서는 인터페이스를 설정 하도록 하더군요.)

2.
NAT 루프백 SNAT 을 설정 합니다.
Chain은 srcnat
Src Address 에 내부 IP (제 경우에는 서브넷 포함해서 10.1.1.0/24로 설정)
Dst Address 에 내부 IP(상동)
Out. Interface 에 내부 브릿지 (bridge-local)
Action에 Masquerade 로 설정 합니다.

===========
이제 인 이웃 잘됩니다. 자동으로 외부 IP를 인식해서 설정 되기 때문에 loopback NAT또는 Hairpin NAT에 이슈가 없을 겁니다.
백두성 2014-12
감사합니다.
좋은 자료 잘 참고하겠습니다.
무아 2015-06
1.
DNAT 의 설정 입니다.
IP -> Firewall -> Address List 에서 dstnat 을 등록할때.

이 부분이 잘 안되는데요. 오타나 뭔가를 빼먹은 것이 있는지요?
     
NAT설정은 IP -> Firewall -> NAT에서 하고 Dst Address List는 Advanced탭에 있습니다.
미크로틱 설정하다가 구글링했는데, 여기까지 왔네요.ㅎ
블랙펄 2021-06
스케쥴에 그대로 복사 넣기했는데요..
그리고  IP->Firewall -> Address List에 external-ip 가 등록

생성이 안됩니다.  방법이 없나요


제목Page 23/28
2015-02   30622   황진우
2015-02   24612   김준연
2015-02   16495   죠짱
2015-01   31342   김준연
2015-01   26647   황진우
2015-01   13311   황진우
2015-01   44901   김준연
2015-01   17622   죠짱
2014-12   14871   김황중
2014-12   18572   김황중
2014-12   21248   죠짱
2014-12   21516   엠브리오
2014-12   20649   stone92김경민
2014-12   19574   dydans
2014-11   19666   황진우
2014-12   15756   monan
2014-11   24714   김황중
2014-11   20996   짱짱맨
2014-11   29182   김황중
2014-11   31955   채선일