[VMWare] esxi 가상머신 네트워크 문의

맑음   
   조회 27273   추천 0    


테스트해볼게 있어서 놀고있는 노트북에esxi 설치후 가상머신을 올렸습니다

가상머신을 설치하니까 기본으로 vSwitch0에 esxi 매니지먼트 포트그룹과 가상머신 vnic가 할당된 포트그룹 하나가 만들어져있고 업링크까지 걸려있어서

따로 추가적인 설정은 안했어요

그런데 여기서 문제가발생합니다...

esxi 랑 가상머신, 그러니까 240번과 250번은 내부통신이라 잘되는데

250에서 밖으로 나가질않네요;;

0.10 - 0.1 - 0.240 구간은 당연히 잘될거고...

포트그룹도 활성화 되어있고 업링크포트도 잘들어가있는데 250은 왜 밖으로 통신이 안되는걸까요??

가상스위치를 하나더 만들어서 거기에 가상머신 포트그룹을 부여하고 업링크포트도 걸어봤지만 여전이 안되네요

아 0.10 노트북이나 0.1 스위치에서 핑테스트하면 핑은 안나가고 arp만 올라옵니다

뭐가문제인지 모르겠어요

김강호 2023-07
ESXi vSwitch 토폴로지에 VM이 접속된걸로 나오나요?
     
맑음 2023-07
포트활성 상태고 vm 접속된거로 나와요
dateno1 2023-07
스위치에 외부 통신을 위한 업링크 추가하셨나요?

그리고 대역폭이 외부에 연결된 네트워크랑 동일한가요? (중간에 라우터라도 없다면 같은 서브넷이야 함)

가상 스위치란게 결국 물리적 스위치랑 동일하게 주소도 통일해야하고, 업링크도 있어야 제대로 외부 통신이 됩니다

예를 들어 외부 네트워크가 192.168.100.0/24라면 가상 스위치의 하위 VM등도 동일하게 192.168.100.0/24를 주고, 업링크용 NIC도 할당해야 합니다

물리적으로는 컴의 NIC에 케이블을 꽃아서 외부 스위치에 접속해둔거지만, 논리적으로는 스위치랑 스위치를 케이블로 연결후 여기 VM이 같이 물려있는겁니다

마지막으로 테스트라면 상관없겠지만, 실재 운영하는거라면 관리용이랑 운영용 NIC를 따로 두고, 각각의 가상 스위치를 생성해서 연결하는걸 추천합니다 (만일 복수의 호스트가 존재한다면 이걸 상호 연동하는 NIC도 따로 둬서 최저 3개정도는 필요하다고 생각해주세요)

https://ibb.co/VTzVQJF
대충 이런식으로 서브넷을 통일해보세요
     
맑음 2023-07
업링크는 vSwitch에 기본적으로 하나 달려있었고 추가로 이중화는 안했어요
네트워크대역은 위에 사진대로에요
같은대역 사용중이요
대역이다르면 arp도 안올라와야할텐데 arp가 올라오는걸보니 구조는 맞는거같아요
          
dateno1 2023-07
vlan id같은거 안 만지셨죠? (기본값 0)

이외의 설정등 혹시 변경하셨다면 MTU 포함해서 죄다 기본으로 되돌려보세요 (기본값 잘 기억 안 나신다면 vSwitch 새로 작성후 거기 업링크등을 포함해서 죄다 옴겨서 연결후 기존 스위치 제거해주세요)

관리 네트워크가 접속이 된다는건 일단 NIC드라이버랑 호스트의 물리적 접속 상태가 문제가 없다는 의미이니 일단 괜찮은 상태라고 가정하고, 관리 네트워크랑 다 통합해서 쓰신다면
https://ibb.co/xs8RNMy
토플로지가 이런 구조가 되어야 합니다

이렇게 되어있나요?
               
맑음 2023-07
네 저렇게 되있어요
아무것도 안건드리고 가상머신에 포트그룹만 지정해둔 상태입니다
vSwitch0 에 업링크포트하나, 가상머신포트그룹하나, 매니지먼트 하나 이렇게 전부 활성화중이요
                    
dateno1 2023-07
GW의 Lan까지는 접근이 되나요?

이후 안 되면 오히려 게스트OS쪽의 설정같은걸 의심해보세요
                         
맑음 2023-07
가상머신 - esxi 끼리는 내부통신이니 당연히 되는데
스위치나 반대편 노트북으로는 안나갑니다
근데 arp는 올라와요
arp도 안올라온다면 구성이잘못됬거나 끊겼단거지만
arp가 올라온다는건 구성이나 연결은 제대로됬는데 vm네트워크 설정이나 어딘가 정책에서 막아둔거같은데....
게스트OS에는 ip랑 서브넷이랑 게이트웨이랑 추가로 vnic 정도만 잡아둔상태에요
게스트os에서 설정이 잘못됬다면 esxi랑도 서로 핑이 안날아갈텐데....
김강호 2023-07
게스트OS를 하나 더 파야 확인이 될 것 같네요.
윈도우라면 PING이 기본 차단되어 있으니 이 부분도 봐야 할거 같고...
     
dateno1 2023-07
정확히는 개인 네트워크는 열려있고, 공용 네트워크는 닫혀있을껍니다
          
maronet 2023-07
업링크에 통신을 제어하기 위한 기능 자체가 없잖아요. 전 그래서 구성상의 실수일 확률이 더 높아 보입니다.
     
맑음 2023-07
음 정확히는 nms를 올린거라서 ip 서브넷 게이트웨이만 잡아주면 통신이되야 정상이라서요
근데 arp만 올라오고 핑은안나가네여
          
김강호 2023-07
어플리이언스라면 더더욱 블랙박스인데 일반OS로 먼저 확인해보는 게 맞지 싶네요
maronet 2023-07
DCUI(콘솔) 또는 쉘로 접속해서 메니지먼트 네트워크에서 외부통신이 되는지부터 확인해보세요.
     
맑음 2023-07
매니지먼트는 잘되요
가상머신만 핑이 안되고 arp만 뜹니다
          
maronet 2023-07
vm이 연결된 포트그룹에 uplink 정확히 매핑되어 있는지 확인해보세요.
               
맑음 2023-07
업링크 확인다햇어요
업링크가 제대로 매핑안되엇으면 arp도 안올라오겟죠
                    
maronet 2023-07
올라오는 mac 주소가 vmnic거인지, vm거인지 확인해보시구요.
vm거임에도 통신이 안된다면 pktcap-uw 명령어로 수준별로 패킷 올라오는지 캡처해서 확인해보세요.
                         
맑음 2023-07
vmnic 제대로 올라옵니다
다만 서버를 처음 만져보니 어디서 문제인지를 모르겟어요,,
                    
maronet 2023-07
vm의 mac 주소가 안보이면, 포트그룹에 업링크 구성이 잘 못됐을 확률이 아주 높습니다.
그 부분 확인해보세요.
                         
맑음 2023-07
포트그룹에 vmnic 를 지정하는건데 vmnic가 올라와야하는거 아닌가요??
설치한 nms 에도 vmnic를 설정해뒀는데요
                    
maronet 2023-07
esxi 관리화면 접속하셔서,
네트워킹 > 가상 스위치 > vSwitch0 > vSwitch 토폴로지 내용
캡처해서 한번 올려보세요.

그리고 vm 연결되어 있는 포트그룹에
포트그룹 편집 > NIC 팀 구성
설정 내용도 올리면 상황 파악에 도움이 될 것 같습니다.
                         
맑음 2023-07
https://ibb.co/c6TZgHg
네트워크 초기화 하고 기본 토폴로지입니다
https://ibb.co/rb7kN7J
기본 포트그룹 nic팀구성정책 입니다
                    
maronet 2023-07
2번째 그림 상태에서 설정 편집 눌렀을 때
NIC 팀 구성 > 페일오버 순서에 vusb0가 보이나요?
보이면 상태가 뭐로 표시되는지 확인해보세요.

vm에 할당되어 있는 mac인 ...39:89, ...39:93은 스위치에서 arp 테이블에서 안보이는 상태인거죠?
usb nic용 드라이버 버전과 esxi 버전이 호환되는 것인지도 봐야할 것 같습니다.
                         
맑음 2023-07
첫번쨰건 지금 퇴근후라 확인이 안되는데
vm에 할당되어잇는 mac 은 스위치에서 arp올라옵니다
arp는 정상적으로 올라오는데 핑이안되요,,,
usb nic랑 esxi 호환성은 호가인을 못해봣는데
호환이안되면 매니지먼트도 접속이 안되는거 아닌가요???
                    
maronet 2023-07
정말 묘한 상황이군요.
지금 사용하시는 esxi와 usb nic 드라이버 버전 좀 알려주세요.
usb 드라이버가 좀 의심되기는 하나,
좀 더 검색해봐야 할 것 같습니다.
                         
맑음 2023-07
esxi 는 7.0 8.0 둘다 같은증상이고
usb nic 는 NEXT-2200GU3, DCLH-G1300 이거두개 사용했습니다
RHNS 2023-07
따로 설정을 바꾸신게없다면 VM 문제보다 OS상의 문제일 가능성이 높아보이네요


제목Page 3/126
2014-05   4408469   정은준1
2015-12   967341   백메가
2023-10   12401   메탈릭
2023-10   9754   회상2
2023-10   7536   dadami
2023-10   6633   메탈릭
2023-10   5435   메탈릭
2023-10   7131   송주환
2023-09   10522   osthek83
2023-09   14717   빅픽챠
2023-09   14235   피일
2023-09   17012   송주환
2023-09   26726   도미노
2023-09   26474   ngoi
2023-09   24412   송주환
2023-09   20768   불량메뚜기
2023-09   20070   준비된백수
2023-08   27902   중립기어오토
2023-08   23106   송주환
2023-08   21010   송주환
2023-08   19025   yexxnoah
2023-08   17342   네버다이