VLAN 설정. Cisco는 되는데 왜 다른 스위치/리눅스 머신에서는 안 될까요?

   조회 364   추천 0    

안녕하세요


저의 IDC 네트워크와 AWS의 네트웍을 Direct Connect으로 연결하려고 있는데요. 말은 복잡하지만 VLAN id 설정하고 라우터에 IP 세팅하고 아주 단순한 BGP 세션 열면 되거든요.

일단 VLAN id 맞추고, 스위치에 VLAN 인터페이스를 만들고 AWS쪽에서 지정해준 IP를 넣었는데. AWS 라우터에서 ARP에 응답을 안 합니다. AWS쪽에 문의하니 자기네쪽에 ARP 패킷 오지 않는 걸로 확인 된다고. 링크도 올라 간 걸로 나오고 패킷 덤프로 보면 802.1Q에 VLAN id까지 맞는 ARP 패킷이 나가거든요.

제가 하도 답답해서 IDC쪽에 성화를 했더니 IDC쪽에서 자기들이 가지고 있는 Cisco 장비(Catalyst 2960-S)로 테스트를 해줬는데. ARP도 잘 받고 ICMP도 잘 주고 받습니다.

저는 Arista Networks 7150S를 쓰고 있는데. 아무리 봐도 뭐가 잘못 됐는지 모르겠네요. 리눅스 장비에 직결해서 리눅스 상에서 VLAN 인터페이스 만들어봐도 ARP가 안 날라 옵니다. 진짜 혹시나 싶어서 SFP 트랜시버도 바꿔봤는데 뭐 당연히 차이 없습니다.

제가 뭔가 놓치고 있는 VLAN 설정이 있을까요?


감사합니다.

짧은글 일수록 신중하게.
윤건 05-15
잘은 모르겠지만
혹시 802.1Q가 아니라 802.1ad로 설정되어야 하는건 아닐까 싶습니다.
     
whatmatrix 05-15
AWS 문서 보면 802.1q라고 나와 있고, 업체에도 혹시 802.1ad Q-in-Q  아니냐고 물어봤는데 아니랩니다 ...

아래가 업체측에서 쓴 config인데 혹시 Cisco는 VLAN 설정하면 알아서 802.1ad도 받아주는식이 되나요?

interface GigabitEthernet1/0/28

switchport access vlan 710
switchport mode trunk

interface Vlan1
no ip address

interface Vlan710
ip address 169.254.96.22 255.255.255.248
          
whatmatrix 05-15
혹시나 싶어서 Catalyst 2960-S 장비 스펙을 봤는데 이 장비는 802.1ad가 안 되는 장비네요. 802.1ad 문제는 아니지 않을까 싶네요.
               
파닥파닥 05-15
저게 2960s config 이면 untagged vlan 에 710 설정해주고 vlan 710 에 ip 할당해서 인터페이스 업 시켰네요

arista 쪽 설정도 untagged vlan 에 710 할당해주고 vlan 인터페이스 ip 할당해서 테스트 해보셧는지요
                    
whatmatrix 05-16
2960s config 맞습니다.

Arista에서 위 config 그대로도 해봤는데요. VLAN interface (Arista에서는 SVI라고 하는거) 만들어서 IP 할당 했고요. 안타깝게도 이렇게 해도 안 되네요.

제가 이해하기로는 업체에서 switchport access vlan 710을 적은건 실수라고 생각이 드는데요. 왜냐면 switchport mode trunk를 설정하면 기본적으로 모든 VLAN을 tagging해서 포트로 보내게 되어 있으니까 vlan 710도 결국 태깅 될 것 같네요. vlan 710을 native vlan으로 설정 했다면 좀 달라지겠지만요.
aws쪽이 태깅포트 맞나요?
     
whatmatrix 05-15
제 장비에서는 AWS 연결 포트 설정을 아래와 같이 했습니다.

switchport mode trunk
switchport trunk allowed vlan 710

이러면 태깅 되서 나가야 될 것 같고 패킷 덤프 봐도 태깅된 ARP 패킷이 나가는 걸로 확인 되더라고요.
윤건 05-15
패킷 덤프가 가능하시니
Cisco장비에서 AWS로 나가는 패킷과
Arista장비에서 AWS로 나가는 패킷을
덤프해서 비교해 보시는게 어떨까 합니다.




QnA
제목Page 5/5211
2014-05   3484631   정은준1
2015-12   97125   백메가
06-24   368   늘파란
06-24   433   미수맨
06-24   352   2CPU최주희
06-24   381   쌉맨트
06-24   313   의롭게살리라
06-24   293   cho609495
06-24   281   죠슈아
06-24   541   영산회상
06-24   693   audacity
06-24   583   레모나맛레몬
06-24   364   죠슈아
06-23   568   매니아1
06-23   577   isaiah
06-23   452   권태영
06-23   434   sdlfkjwer
06-23   381   그린
06-23   324   호호
06-23   257   안철현
06-23   267   박문형
06-23   231   영산회상